6
Vote

Activate selected features not working i VS2012 on CKSDEV 1.2

description

Trying to set up a suitable selection of features in "Select Features to activate", and then creating a proper configuration for deploy using the selective activation, but cannot find any step like "Activate selected features" in the step-list in VS2012. So then I'm stuck unable to use this neat feature..

According to this discussion - http://cksdev.codeplex.com/discussions/454742 - I'm not alone struggling with this in VS2012 and CKSDEV 1.2.

Hoping for a fix of course =)

Brgds,
Gunnar

comments

edhalsim wrote Apr 1, 2014 at 7:48 PM

Did you ever come up with a resolution/work around for this?

wrote Sep 17, 2014 at 4:56 PM

katman26 wrote Sep 17, 2014 at 4:57 PM

I don't know if this is related, but I'm getting the following error -
Error 12 Error occurred in deployment step 'Activate selected Features': Error in line 1 position 313. Element 'http://schemas.datacontract.org/2004/07/Microsoft.VisualStudio.SharePoint.Commands:Value' contains data from a type that maps to the name 'http://schemas.datacontract.org/2004/07/CKS.Dev12.VisualStudio.SharePoint.Deployment.DeploymentSteps:FeatureActivationInfo'. The deserializer has no knowledge of any type that maps to this name. Consider using a DataContractResolver or add the type corresponding to 'FeatureActivationInfo' to the list of known types - for example, by using the KnownTypeAttribute attribute or by adding it to the list of known types passed to DataContractSerializer.