Visual Studio 2015

Mar 2, 2015 at 1:42 PM
Any plans to create a Visual Studio 2015 version of the CKS: Development Tools? I'd be glad to help out.
Apr 29, 2015 at 1:48 PM
Since CKSDev is not even really working with Visual Studio 2013 Update 4, I highly doubt a release for VS15.
Jul 20, 2015 at 11:02 PM
That sounds like it.

I think with the App model emphasis, this project is not getting as much love now. However, for many transition into a new development paradigm should be gradual and thus this tooling is quite relevant.

I hope the maintainers will hear us and get back to updating wonderful extension.
Jul 24, 2015 at 8:32 AM
We've installed the 2013 CKSDev version to our Visual Studio 2015 version.

You can manipulate the extension manifest to add "support" for Visual Studio 2015.

To the following:
<PackageManifest Version="2.0.0" xmlns="">
    <Identity Id="CKS.Dev12" Version="2.0" Language="en-US" Publisher="CKSDev Team" />
    <DisplayName>CKS - Dev for Visual Studio 2015 - Unofficial</DisplayName>
    <Description xml:space="preserve">The CKS - Development Tools Edition for Visual Studio 2015 is an unofficial modified collection of Visual Studio templates, Server Explorer extensions and tools providing accelerated SharePoint 2010/2013 development based on Microsoft's SharePoint 2010/2013 development tools.</Description>
    <Tags>SP2010, SP2013</Tags>
    <InstallationTarget Version="[13.0,14.0]" Id="Microsoft.VisualStudio.Pro" />
    <InstallationTarget Version="[13.0,14.0]" Id="Microsoft.VisualStudio.Ultimate" />
    <InstallationTarget Version="[13.0,14.0]" Id="Microsoft.VisualStudio.Premium" />
    <Dependency Id="Microsoft.Framework.NDP" DisplayName="Microsoft .NET Framework" Version="[4.5,]" />
    <Dependency Id="Microsoft.VisualStudio.MPF.12.0" DisplayName="Visual Studio MPF 12.0" Version="[12.0]" />
    <Asset Type="Microsoft.VisualStudio.VsPackage" Path="CKS.Dev.VS2013.pkgdef" />
    <Asset Type="Microsoft.VisualStudio.Assembly" Path="CKS.Dev12.dll" AssemblyName="CKS.Dev12, Version=, Culture=neutral, PublicKeyToken=487fd6341a5c701f" />
    <Asset Type="Microsoft.VisualStudio.MefComponent" Path="CKS.Dev12.dll" />
    <Asset Type="SharePoint.Commands.v4" Path="CKS.Dev12.Cmd.Imp.v4.dll" AssemblyName="CKS.Dev12.Cmd.Imp.v4, Version=, Culture=neutral, PublicKeyToken=487fd6341a5c701f" />
    <Asset Type="SharePoint.Commands.v5" Path="CKS.Dev12.Cmd.Imp.v5.dll" AssemblyName="CKS.Dev12.Cmd.Imp.v5, Version=, Culture=neutral, PublicKeyToken=487fd6341a5c701f" />
Works like a charm and no errors so far.
Aug 19, 2015 at 7:42 PM
Thanks, Rummskull! Worked great for me too.
Sep 9, 2015 at 8:27 AM
This only works if you have visual studio 2013 AND 2015 installed.

If you have a clean VS2015, then cksdev still points to the old visual studio dll's and fails.
Sep 9, 2015 at 7:00 PM
I think we need make a full copy of hte Cks.Dev.VS2013 as *.VS2015 and then change the references appropriately. I can attempt to do that in my dev box at the end of the week. I'd like to get the CKSDEV going on the clean dev VM with only VS2015 installed as well.

@xtrmdev, can you post the error details you're getting for reference?
Sep 17, 2015 at 9:02 AM
Sorry missed this one, but this is the error:

Could not load file or assembly 'Microsoft.VisualStudio.SharePoint.Commands, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

On quick deploy, copy to gac.
Oct 11, 2015 at 2:55 PM
Ok, had to get this fixed so i fixed it myself.
I didn't bother to upload this is a patch or something, i don't have time for that. Such a tedious process.

Note, this is a CLEAN VS2015 version, all the crap directives for old VS editions has been completely removed.
That was never a good idea to have support for all VS editions in one project.
The source was copied for every VS edition anyway. And it got more and more bloated for every VS release.

I can understand why this project hasn't been updated. It took me 4 hours just to rip that crap out of the project and get everything right.

Let's face it, this project is dying, so a minimum of effort is required to keep it alive.
Next time VS2016 comes out, take a copy, rename 2015 to 2016 globally, fix framework settings and references and youre done.
Stop supporting old crap, users that use VS2013, can use the extension already released. If they want a fix, then UPGRADE to latest version of VS
or leave it.

I haven't really tested it very well.
I have installed the signed vsix file which is included in the zip. And i removed VS2013, leaving VS2015 only.
Quick deploy menu has been tested and working, like copy to SharePoint root / gac etc.
Works for me.

Anyway this isn't a "offical solution", so use at own risk.
Dec 10, 2015 at 8:25 PM
Edited Dec 10, 2015 at 8:30 PM
@xtrmdev, big big BIG thanks!!!
It's a pity that maintainers of this project are gone.

edited .vsixmanifest file was not working for me, but can confirm that @xtrmdev's solution works on clean 2015 (without 2013) environment without issues.
Dec 11, 2015 at 7:44 PM
I am not able to download @xtrmdev copy.

I'll have to follow my previous comment and make my own copy. hehe :)
Dec 15, 2015 at 8:56 AM
Humm i just downloaded it, it is still up here.
Maybe dropbox had some problems :)
Feb 5, 2016 at 10:55 PM

I finally got a chance to try again. It's there. Thanks for your hard work.