Error using Quick Deploy - "The path is not of a legal form"

Oct 11, 2010 at 7:28 PM

Hi.  I'm using Visual Studio 2010 (version 10.0.30319.1) with the CKS dev tool.  I have two projects in the solution, one is a blank SP project, the other is an empty project (SharePoint.Core).  The SP project references the other empty project.  When I right click on the SP project and I go to Quick Deploy (CKS Dev) -> Copty to GAC/Bin I get the following error:  "The path is not of a legal form".  Here's what's shown in my output.  Any idea what's going on?  Thanks.


========== Copying to GAC/BIN ==========

------ Quick Copying Binaries: SharePoint.Features ------{ProjectRoot}\pkg\Debug\SharePoint.Features\SharePoint.Core.dll -> GAC

Oct 27, 2010 at 4:36 PM

Can you provide the names of the projects and their file system paths so we can recreate the same project layout?



Mar 29, 2011 at 9:16 AM

This also happened to me when I set the output dll to not be included in the package (Project Properties). I instead manually added it through the Additional Assemblies section of the Package explorer. This allowed me to configure the Safe Controls settings explicitly. I reverted however when I saw CKSDEV didn't handle this situation as Copy to GAC is very useful!

Jun 21, 2011 at 9:24 AM

jstrugnell is right. We had the very same problem with adding the output dll to the package manually for "safe controls" settings.

Please fix that! :(


@jstrugnell: What workaround did you use in order to use CKSDEV quick deploy along with safe controls?